2012 Millennium laser not working


Recommended Posts

I just received my machine a week or so ago. I have been reading everything cover to cover, watching youtube vids, watched the included DVD....and I can't get the laser to come on. The DVD isn't for my year model machine, it is for 2010 which doesn't help much. The machine is set up beautifully....and I want to quilt! :)

The laser is plugged in securely. I have tried it on the rear and front of the machine...still no laser light. I can't seem to find a specific on/off switch for it...and zero instructions.

Can anyone help? :)

Thanks!

-Jo

Link to post
Share on other sites

I have a 2010 Millennium. They eliminated the on/off switch for the laser light. You just push in the plug or pull it out for turning on and off. As you stand at the back of the machine, the plug is located on the rear left of the machine, behind the stitch regulator. If it does not work when plugged in, have you tried fiddling with the laser light itself--sometimes they need a little twist to connect and light up.

Link to post
Share on other sites

Hello Joan,

Thank you for the fast reply. :) Unfortunately, I have fiddled with it, plugged it in both front and back....and it just doesn't come on. What should I try next? That is good information about the on/off switch. At least I won't keep looking for one :)

-Jo

Jo, give APQS a call first thing tomorrow morning - it's just possible that you have a bad laser. If the light's not defective, Amy or one of the other techs can certainly talk you through getting it working properly. You can also post here on the "APQS Help" forum - they check that one regularly - or send an email to Dawn or Amy. We'll get you shining yet!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...