Jump to content

Thread looping around the needle and breaking, help!


Recommended Posts

I have a 2008 Millenium that I have had for almost a year. The last few weeks I have had a horrible time with the thread looping around the needle and getting stuck, causing the thread to break as I move on. This usually happens on straight lines, when I stop the motor and pause to move the ruler and the restart the motor and move on. But it has also happened during stitching. Occasionally I get a skipped stitch just before it loops. I don't seem to have any trouble during free motion work or pantos. At the moment, I am using Signature, but the same thing happens with So Fine. The thread feels 'loose' between the tensioner and the needle. 


 


I am going crazy here. I can't run a business like this. This is what I've tried:


-changed the needle and tried different sizes


-put in a brand new bobbin case


-checked for burrs on all the thread guides and changed the pigtails


-checked for burrs on the hook (I did find several little nicks which I sanded out)


-checked for burrs on the retaining finger (found one and sanded it out)


-checked for burrs on the needle plate


 


I wasn't sure if it was the way I am moving the machine, but I have had it since last May, and I haven't had this trouble until now. Please help!post-51563-0-81595600-1426374339_thumb.jpgpost-51563-0-36322000-1426374399_thumb.jpg


Link to comment
Share on other sites

I know this sounds crazy, but unthread the top thread completely, then start over from scratch. Put a piece of batting in the first thread guide above the cone..not jammed in tight, but tight enough for the thread not to wander around in the guide. Check the cone of thread to make sure there is not a rough spot that the thread is catching on. When I have had this happen, it is usually due to a sudden change in top thread tension. Watch your top thread and see if there is a point at which you have a lot of slack in the thread, because that is what causes those loops to form around the needle. What type thread are you using? Try using a thread net around your cone. Try loosening your quilt a bit on the frame. I feel for you. If none of those things help, call APQS on Monday.

Edited to change "buttress" to "unthread" but sometimes autocorrect is hilarious!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...