Bobbin Thread Sometimes Doesn't Come Up


Recommended Posts

I have a millienium. After I complete a line of stitching and use the bobbin thread cutter, I'll go to a new spot and attempt to bring up the bobbin thread. Sometimes the thread will not come up. When I remove the bobbin and case from the machine base, it appears that everything is okay -- in other words, the thread is threaded appropriately from the bobbin and through the slits in the bobbin case. But, I will have to remove the bobbin from the case and re-insert the thread through the bobbin case guides, then put it back into the machine base, before the thread will come up. This doesn't happen often, but when it does, it seems to happen repeatedly and takes a lot of time (and frustration). Any clues as to why this may happen? Thanks for your help!

Link to post
Share on other sites

Hi,

Mine does that sometimes too. The only thing I can figure out is that the thread cutter is cutting the bobbin thread too short for the needle to then be able to pick it up and bring it to the top. I've recently learned that if you bring the bobbin thread to the top, and cut both threads at the same time you don't have to trim thread tails after you finish quilting. This is my new method of cutting bobbin thread. Good luck to you.

Beth

Link to post
Share on other sites

I just got a Millennium and in the video, it states that after you finish your line of stitches, move the needle over a couple of inches before pressing the automatic bobbin thread cutter button. Doing this will leave a longer tail for the bobbin the next time you pull it up to the top. Give that a try. Hope that works for ya! :) Remember you will have little strings to snip off the back when your done. Or, you can do what Beth does and bring the bobbin thread up at the end of your stitches and tie, bury and snip off from the top.

Link to post
Share on other sites

Hi LadyLake,

I'm with Beth, if the thread cutter cuts too short, you have to pull the bobbin out, rethread and put it back in. I don't use my thread cutter since I was taught how to pull that bobbin thread up. It just takes practice but for me, this is just easier and really saves time on clean-up when the quilt is done.

When you have finished stitching an area, backtrack 2 -3 stitches to lock the stitches, hit stop, move the machine aside 2-3 inches leaving a thread trailing back to the hole from the needle.

Grab the thread tail and hang onto it as you pull the machine back to that hole.

Hit the 1-stitch button and let it cycle. Then move the machine again. You should still have a hold of the top thread and notice that it dragged the bobbin thread to the surface.

Snip and you're done. (or tie off, bury the knot, then snip). I don't tie off and bury. If I was doing a quilt for a show I would consider that extra effort. But mostly I just backtrack, pull up the bobbin, snip and go. I try to minimize my stops and starts but sometimes you can't. So I don't like my thread hanging on the top or the bottom. I will invariably run thru that loose thead and make a mess. Grrrr.

If you prefer to use the thread-cutter, one of the super techs at APQS can probably tell you how to fix it.

Happy quilting.

Link to post
Share on other sites

Mine does something like that. When I use the thread cutter then try to pickup the thread in another spot, the bobbin thread will not come up. When I reach under to get the bobbin case, the thread is stuck and will not come out. I cannot figure out where it is hung up, but if I unthread the needle and needle up/down, it will come out. Otherwise I just try to pull it out gently. That is about the most frustrating thing ever. I have tried everything. Dawn C. even told me to hold the loose end of the bobbin thread over that little flappy thing when inserting the case back into the machine. I've tried it - it doesn't help. I'm trying to get used to picking up my bobbin thread and cutting it from the top after a row of stitching, however, if the thread breaks, I usually go through the bobbin thread problem.

Link to post
Share on other sites

Thanks to all of you for the information -- this internet communication is wonderful! I have gotten in the habit of just using the bobbin thread cutter, rather than pulling the thread up, and forgot that most long armers pull it up and clip. It makes sense what you all said about why the thread doesn't come up -- because it is clipped too short. I'll plan to move the machine over a bit before clipping in the future. I also experience the "thread being stuck in the case" problem, Mary Beth, and end up manually moving the flywheel to work the bobbin out. I would imagine one of the engineers might know why this happens, but maybe if the machine is moved before using the bobbin cutter, it won't happen.

I thought I'd share with you how I handle thread ends, in case you are interested. For my own style of quilting, which usually involves lots of starts and stops, I clip all of the bobbin threads when the quilting is completed by going to the back of the machine and gradually rolling the quilt; I use this time to closely check over the stitching on the back and correct any problems at that time. For me, this takes less time and effort than repeatedly grabbing the scissors (I don't like to have them hanging on my neck), doing the finger work to one stitch up/down, pull up the thread and clip, and then move to throw the thread away in the trash can (I don't like to have thread ends sticking on my shoulder).

My dream would be to have a bobbin thread cutter that clips the ends 1/8" or less. I have heard that the domestic sewing machine companies are close to offering this; perhaps the long arm manufacturers will follow suit. It would save lots of time.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...