Recommended Posts

When I initially turn on my Millenium and attempt to sew, I find that the one stitch button as well as the fly wheel do not act properly. The one stitch button goes a full cycle (down and up) not the required half cycle (just down). The fly wheel seems ot have a life of its own, continuously vibrating and making the bobbin case chatter too.

I've learned that if I warm the machine up for 10 mins before sewing its gets better but not for the last few times. The chattering of the fly wheel continued through one full hour of quilting.

What adjustments do I need to be making?

Share this post


Link to post
Share on other sites

When this happens to me it is a easy adjustment. There is a little brass screw under the cover on the right side (when looking from the front to the back). The screw is towards the top of the panel and towards the front. If you have the maintainence video, they should how to make this adjustment. Otherwise search old posts here as there was a more detailed description. I believe I just give the screw a small turn to the right.

Nancy

Share this post


Link to post
Share on other sites

Hi,

The adjustment is the # 8 blue pod, as Nancy said, it is up under the cover and towards the front of the machine. It is the only blue pod with the screw coming out the side, all the other screws are out the top! Turn it 1 full turn counter clockwise.. (after you have ran the machine for 10 min..) if that is to fast or if it takes more than 1 stitch turn it back a little..

When making this adjustment, always have the machine warmed up, as the adjustment will be more accurate.. also start with 1 full turn.. sometimes when doing only 1/4 to 1/2 turn you will have to make the adjustment again in the near future!

Good Luck

Let me know if you need anything.

Connie Hurst

APQS Service Mgr/Tech.


Connie Hurst

APQS Service Mgr/Tech.

800-426-7233 ext. 6

Share this post


Link to post
Share on other sites

I just got an lt II from one of your members and I am having similar problems with the motor belt vibrating and the bobbin case rattling. My thread is breaking every few inches unless I have the tension all the way down, then I get loops on the backside. Any suggestions. Thanks


8259635bf834a637a7febcce54170daf.png Sweet T's Custom Quilting Finley, TN  (731)-445-6411 sweet_t_quilting@yahoo.com

 

http://sweettsquilting.blogspot.com

https://www.facebook.com/SweetTsQuilting

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...