Jump to content

Help with my Lenni

Recommended Posts

My Lenni has been sitting for several months without running.  I turned it on and tried to start quilting...I keep having thread breakage...I've changed the needle and adjusted the tension.  Nothing seems to help.  Also, it runs on manual, with thread breakage too, but when I put it in stitch regulator mode, and press the button the handle to run, it doesn't run....what now?




Link to comment
Share on other sites

Sorry you are having problems.  I would unplug and then plug back in. I would re-thread. I would also clean my bobbin case.  Might try a different bobbin.  Try and identifie if thread is breaking in a particular motion/direction.

Link to comment
Share on other sites

Yeah!!!  My honey worked with me this morning and we have my Lenni back up and running!  After a thorough cleaning and oiling, my honey found that one of my encoder cables had a broken wire.  Luckily when I first got my used machine we had trouble setting it up and called APQS for help.  We asked what extra parts we should have on hand and they recommended we have 2 cables.  Thanks APQS....I can now get my quilts completed!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...