Recommended Posts

Hi everyone. I am experiencing shredding of my top thread today. I’m using Omni thread top and bottom and I have a Millie. I hardly ever have this issue but I can’t seem to figure it out. Omni is always my go to thread that always worked in her. I’ve rethreaded, changed needles, cleaned everything. What else could it be? I’m open to all suggestions. Thanks.

Link to post
Share on other sites

Have you checked for burrs?  Also check to see if the thread guides have worn down into a groove.  It they have try turning them upside down so the thread is running through a different part of the guide.  If you can work out where on the thread path the shredding occurs it will give you an idea which area to check.

Good luck.

Link to post
Share on other sites

I’m hoping this was the answer. I’ve had this cone of thread for a long time. I put some Sewers Aid on it last night and let it sit. So far this morning it’s stitching beautiful. But...and there’s always a but...   I was doing a pantograph and as usual the cone unwinding as I sew catches my eye. I stopped and looked and part of the thread was unwinding/raveling when it came off the cone. So now I’m wondering if I have a bad cone of Omni thread. I unwound a bunch of it and rewound some bobbins with it and haven’t seen anymore. I’m thinking this is what happened when the thread was breaking/raveling down by the needle.  Thanks for your suggestions and I did check for burrs and have none. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...