Jump to content

Needle up/down won’t work and machine buzzes

Recommended Posts

I turned Freddie on this evening and it was buzzing as if it were in “go” mode. I tried to needle up/down and nothing happened. I moved the machine and it didn’t go. I toggled to start and the needle went up and down fine. Regulation mode seemed a little off. Toggled to stop and the machine continues to buzz. Needle up/down still doesn’t work. Anyone have ideas? I removed the thread and the bobbin and it didn’t help. Unplugged and plugged back in, nothing. Don’t want to be too wild because I have no idea what I’m doing. 

Link to comment
Share on other sites

Did you turn the speed as low as it will go?  The machines don’t actually run at that speed - you have to increase the speed just a smidge. However, the needle up/down should still work. 
Have you checked all the cable connections?  Did you unplug anything?  It’s possible to swap the SR and handle cables - I’ve done it. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...