DMCP

Motorized feed. Noise and movement

Recommended Posts

So....noticed a noise when using motorized feed.    This caused me to look at the motor.  I see slight but noticeable movement of the motor.  Not sure why the noise but it is associated.  Also noticed some dark shavings, that I assume to be coming off of the rubber teeth.  Any ideas?  Do you see any movement on yours?   TIA.     2004 Millie


DebMcP

Share this post


Link to post
Share on other sites

Make sure the mounting is secure and tight.  I had my motor loosen up and nearly fall off the shaft one time.  I make sure I check to make sure the rubber teeth are tight when I check all the nuts and bolts during complete cleaning maintenance times.


Norma H with Schultzi, my Blissed Millie - Circle Lord and Quiltazoid enhanced

Share this post


Link to post
Share on other sites

You should check the motor brushes in the power advance, especially if your 2004 model hasn't had them replaced before. Worn brushes cause an erratic electrical connection and can make the motor sound different. They are easy to replace and easy to find. The shavings could also be graphite from the worn brushes. Look in your manual for where they are and how to replace them. 


Linda Rech

Finely Finished Quilts

Millennium on Bliss rails--hand-guided

http://www.topperquilttools.com

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...